Making your plugins compatible with Shopware 5.2

Plugin-compatibility-with-Shopware-5-2

Zum deutschen Artikel

As a plugin manufacturer, it’s always important to keep your plugins up-to-date in the Community Store. When your plugins are incompatible, you take the risk of your customers switching to competitors whose plugins offer compatibility with their upgraded Shopware shop.

To help you avoid this risk and make your plugins more attractive, we’ve summarized the most important information for making your plugins compatible with the latest Shopware release.

Golden rule: compatibility with Shopware 5.2

If you want to make your plugins compatible with Shopware 5.2, they have to be able to run under PHP 5.6 and PHP 7.x. It’s important that the plugins be updated from the file basis. As of PHP 5.6, encrypted plugins are encrypted using a more recent version of IonCube.

The reason behind this is because a new version of IonCube is required for PHP 7. This means that all encoded plugins must exist in a compatible version using the new encoder. As soon as shop owners download your plugin via the Plugin Manager with Shopware 5.2, the newly encoded versions are automatically downloaded. More information can be found here.

Plugins developed with the new plugin system

Back at the 2016 Shopware Community Day, we presented a new plugin system that offered even more possibilities for developing extensions for Shopware 5.2. This new system offers a number of advantages, especially from a technical point of view. You can find more information and examples in our tutorial.

Automatic compatibility with bugfix versions

We regularly make bugfix releases available to the Community. Under “Plugin Management > Plugin version association” in your account, you can automatically assign your plugins as being compatible with the latest Shopware version. The only prerequisite is that your extension has already been authorized for release in the same release cycle. This will automatically authorize your plugin for all bugfix versions with just one click – say goodbye to manual maintenance paths.

Take the leap and go open source

Openness is our most important company value. In fact, after going open source in 2010, our software received an enormous boost in terms of distribution and use. That’s why the next logical step was to offer the open source version of our plugins, which is what we’ve pursued since the release of Shopware 5.2. In addition, when looking into the requirements of projects, several explicitly require only open source extensions be used.

Your advantages:

  • Your plugins become more modular and versatile
  • You benefit from a higher acceptance and more widespread use
  • It’s much easier and quicker for other developers to create extensions or modules for your plugins
  • Your plugins become all the more attractive

Protection against unlawful spread

In the case of possible license violations, the shop owner will receive a popup notification in their backend as well as in their Plugin Manager. It is also impossible for stolen copies of your work to access updates or support. These two measures were designed to ensure the security of your plugins. We are convinced that anyone who professionally operates an eCommerce site would be more inclined to purchase your work then run the risk of operating stolen content.

As of Shopware 5.2, you can easily offer your plugins as open source – plugins prior to Shopware 5.2 should remain encrypted.

Step 1:
Open your account and head to “Plugin Management > Plugin Overview” and edit the respective plugin.

Step 2:
Important: in the editing module, the settings under “Additional options” should remain unchanged. So the options “I want to encrypt my plugin with IonCube” and “Shopware license check” should remain checked. It is important that nothing is changed here, otherwise all versions for prior Shopware releases (5.1, 5.0, etc.) will also be unencrypted.

Step 3:
Now upload the new plugin version and uncheck the boxes for “I want to encrypt my plugin with IonCube” and “Shopware license check”.

Plugin updates for older Shopware versions

When you’d like to offer plugins that are compatible with older Shopware versions, the options next to “I want to encrypt my plugin with IonCube” and “Shopware license check” must remain checked for plugin versions compatible with anything earlier than Shopware 5.2. In other words: the additional options must remain unchanged.

comments powered by Disqus